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Page 331-01-2020

Interface

Les icônes ont été redessinées avec un style moderne et une nouvelle palette de couleurs afin de pouvoir gérer les écrans

hautes résolutions (4K). Cela inclut les icônes dans les menus, dans les barres d'outils, dans les boîtes de dialogue et dans les

panneaux ancrables.

• FEMAP 2019.1

• FEMAP 2020.1



Page 431-01-2020

Interface

Mise à jour des boutons «Palette» dans toute l'interface utilisateur pour afficher la couleur actuelle de chaque entité

ainsi que le motif actuel, si une autre que celle par défaut est affectée.



Page 531-01-2020

Arbre Model Info
Nouvelle branche Simulation Entities

Ajout de la branche Simulation Entities et des branches sous-jacentes Monitor Points et Matrix Inputs, qui permettent

respectivement la gestion, l'édition, la liste, la suppression et la renumérotation des Monitor Points et les Matrix Inputs.

Pour les Monitor Points , la couleur et le calque peuvent également être modifiés.



Page 631-01-2020

Arbre Model Info
Nouvelle branche Tables

Ajout de la branche Tables sous la branche Model, qui permet de recharger/modifier une entité Table ou de supprimer les

tables en surbrillances ou de les renuméroter.



Page 731-01-2020

Arbre Model Info
Nouvelle option de Data Surfaces

Ajout de la commande Renumber au menu contextuel des Data Surfaces, qui renumérote la ou les Data Surfaces en

surbrillances.



Page 831-01-2020

Arbre Model Info

Fonctionnalité améliorée des commandes qui créent un nouvel Loat Set ou un ensemble Contraints Set pour «étendre»

automatiquement l'ensemble nouvellement créé dans l'arborescence du panneau Model Info.



Page 931-01-2020

Arbre Model Info

Commande Copy To Set améliorée dans les menus contextuels de la définition de Chargements ou Contraintes pour

permettre de copier les définitions de Chargements/Contraintes en surbrillance dans plusieurs Load Set/Constraints Set en

même temps.

Avant FEMAP 2020.1



Page 1031-01-2020

Menu
Model/Delete Simulation Entities

Ajout dans le Menu Model de Simulation Entities utilisé pour créer des Monitor Points et/ou Direct Matrix Input

Ajout dans le Menu Delete>Model les choix  Monitor Points et Direct Matrix Input utilisés pour supprimer les Monitor 

Points et Direct Matrix Input, respectivement.



Page 1131-01-2020

Menu
Nouvelle commande Tools>Check>Mesh Interference

Ajout de la commande Tools>Check>Mesh Interference. Cette commande examine un ensemble d'éléments pour déterminer

si l'un des éléments sélectionnés interfère (c'est-à-dire si l'élément traverse et/ou chevauche un autre élément) avec l'un des

autres éléments sélectionnés.

Interférences 3D/3D Interférences 2D/2D

Interférences 1D/2D/3D
Interférences 1D/1D



Page 1231-01-2020

Menu
Nouvelle option de Tools>Coïncident Check>Nodes

Mise à jour de la commande Tools>Check>Coïncident Nodes en ajoutant l'option Delete Midside Nodes in Linear/Para-

bolic Transitions qui supprimera tous les nœuds intermédiaires sur les éléments paraboliques qui passent à des éléments

linéaires après la fusion des nœuds de coins.



Page 1331-01-2020

Menu
Nouvelles options de la commande Tools>Check>Sum Forces

Mise à jour de la commande Tools>Check>Sum Forces pour pouvoir répertorier la somme des charges individuelles pour

All Load Sets ou n'importe quel Selected Load Sets.

De plus, Send Summation(s) to Data Table a été ajoutée pour envoyer la sommation individuelle pour chaque Load Set à la

Data Table.



Page 1431-01-2020

Préférences
Onglet Graphics

Amélioration du contrôle pour les valeurs réelles affichées dans la fenêtre graphique. Pour définir les paramètres globaux du

contrôle des chiffres, utiliser la commande File>Preferences, choisir l'onglet Graphics, puis utiliser les options à l'aide des

boutons Locale et Options ... dans la section Digit Control.



Page 1531-01-2020

Préférences
Onglet Message

Mise à jour de tous les boutons «Palette» avec des boutons «bloc de couleur» qui affichent désormais la couleur de l'entité, y

compris les paramètres de transparence. De plus, si un paramètre pour le style de ligne est spécifié, il sera également

affiché sous le «bloc de couleur» du bouton.



Page 1631-01-2020

Préférences
Onglet Interfaces

Ajout de l'option Skip DMIG Bulk Data Entries dans la section Nastran Options. Lorsque cette option est désactivée (défaut) les entrées

DMIG rencontrées dans la section Bulk Data du fichier Nastran deviendront des entités Direct Matrix Input dans FEMAP.



Page 1731-01-2020

Démonstration

01-interference.modfem
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Page 1931-01-2020

Géométrie
Interfaces

Interface FEMAP 2020.1

Parasolid 32.0

Solid Edge 2020

Pro/Engineer Creo5

CATIA V5-6 R2018 SP2

Solidworks 2019

ACIS 2019.1.0.1

NX 2019

JT 10.0

IGES 4.0-5.3

STEP AP203, AP214

Les interfaces FEMAP suivantes ont été mises à jour pour prendre en charge les nouveaux formats de géométrie :



Page 2031-01-2020

Géométrie
Ajout option Geometry

Pour les commandes Geometry>Copy, Geometry>Rotate, Geometry>Reflect, ajout de l'option Coordinate Systems à la

section Other Entities to Include. De plus, création d’une nouvelle section Parameters, changement de Copy to Active

Layer à Assign to Active Layer et nouvelles options Assign Active Color… et Assign to Active CSys.



Page 2131-01-2020

Géométrie
Ajout option Modify

Pour les commandes Modify>Move By..., Modify>Rotate By..., Modify>Reflect... et Modify>Align ajout de l'option

Coordinate Systems à la section Other Entities to Include.



Page 2231-01-2020

Géométrie
Ajout option Washer

Ajout de l'option Alignment lors de la création de washer via l'outil Geometry Editing dans la Meshing Toolbox

(uniformisation avec la fonction Pad).

Automatic Vector Tangent to Curve Perpendicular to Curve



Page 2331-01-2020

Géométrie
Nouvelle commande déplacement géométrie (1/2)

Ajout de l'option Smart Select, ainsi que des options Offset, Identical, Concentric, Colinear et Tangent Edges, pour

contrôler l'ajout automatique de surfaces à un ensemble de surfaces déjà sélectionnées (Synchronous Technology). De plus,

lorsque Operation est défini sur Translate Surface(s), ajout du menu déroulant Translate Mode, qui offre plusieurs options.



Page 2431-01-2020

Géométrie
Nouvelle commande déplacement géométrie (2/2)



Page 2531-01-2020

Géométrie
Amélioration MeshingToolbox

Amélioration de la suppression des congés, y compris les congés en escalier, lors de l'utilisation des commandes et des

fonctionnalités de la Meshing Toolbox.



Page 2631-01-2020

Démonstrations

03-Synchronous-init.modfem
02-washer-init.modfem
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Page 2831-01-2020

Maillage
Collage des nœuds (1/2)

Mise à jour de la commande Mesh>Geometry>Solids en ajoutant l'option 2..Into Model à la liste déroulante Merge Nodes

de la boîte de dialogue Automesh Solids. Cela diffère de 1..New Nodes, qui ne fusionne pas les nœuds du maillage

nouvellement créé avec les nœuds du maillage existant actuellement, et 3..All Nodes, qui effectue simplement une fusion de

nœuds pour tous les nœuds du modèle.

0 = Off : aucun nœud entre les solides n’est mergé

1 = New Nodes : fusionne uniquement les nœuds entre les solides maillés 

lors de la commande en cours. 

2 = Into Model : les nœuds nouvellement créés sont fusionnés en eux-

mêmes et à tous les nœuds coïncidents existants dans le modèle. 

3 = All Nodes : les nœuds sont fusionnés sur l'ensemble du modèle.



Page 3031-01-2020

Maillage
Sélection

Ajout de l'option Model Free Edges à la boîte de dialogue Edge Selection qui est maintenant utilisée dans un certain

nombre de commandes de maillage. Lorsque cette option est sélectionnée, tous les bords libres des éléments pris en

compte par la commande seront automatiquement sélectionnés.



Page 3131-01-2020

Maillage
Copie/Rotation/Symétrie

Pour les commandes Mesh>Copy, Mesh>Rotate, Mesh>Reflect, ajout de l'option Coordinate Systems à la section Other

Entities to Include De plus, création d’une nouvelle section Parameters, changement de Copy to Active Layer à Assign

to Active Layer et nouvelles options Assign Active Color… et Assign to Active CSys.



Page 3231-01-2020

Maillage
Déplacement/Rotation/Symétrie/Alignement

Pour les commandes Modify>Move By..., Modify>Rotate By..., Modify>Reflect... et Modify>Align ajout de l'option

Coordinate Systems à la section Other Entities to Include.



Page 3331-01-2020

Maillage
Connexions (1/2)

La commande Mesh>Connect>Rigid a été mise à jour :

- Les options Independent DOF (Target) et Dependent DOF

(Source) sont déplacées en haut de la boîte de dialogue

- L'option Preview Target Nodes a été déplacée dans la

section Target Node Selection

- Une nouvelle section Node Pairing Options a été créée. Elle

contient deux nouvelles options :

o Allow target node to be mapped to multiple source

node : permet à tout nœud cible d'être couplé avec un

nombre illimité de nœuds source (s'il est désactivé,

uniquement les paires avec le nœud source le plus

proche) et

o Minimum target(s) per source : garantit que les

éléments ne seront créés que lorsqu'un nœud source

trouve au moins le nombre spécifié de nœuds cibles à

l'aide des paramètres spécifiés.



Page 3431-01-2020

Maillage
Connexions (2/2)



Page 3531-01-2020

Maillage
Extrusion

Mise à jour de la commande Mesh>Extrude... afin d’utiliser la boîte de dialogue standard Edge Selection quand la

méthode choisie est Along Element Edges.



Page 3631-01-2020

Maillage
Sweep (1/2)

Mise à jour de la commande Mesh>Sweep avec ajout de Merge Nodes to Adjacent Elements et Limit Sweep to

Visible Mesh dans la section Options.

Ces options sont disponibles uniquement quand Method est choisie à Along Element Edges.

o Merge Nodes to Adjacent Elements : Merge automatiquement les nœuds des nouveaux

éléments aux éléments déjà existants

o Limit Sweep to Visible Mesh : Exécute l’opération uniquement sur le maillage visible



Page 3731-01-2020

Maillage
Sweep (2/2)



Page 3831-01-2020

Maillage
Edge/Skin Elements (1/2)

Mise à jour de la commande Mesh>Edge/Skin Elements>Planar Elements on Faces pour afficher la boîte de dialogue

standard Face Selection au lieu d'avoir à sélectionner les éléments, puis les faces.

De plus, la commande Mesh>Edge/Skin Elements>Line Elements on Edges a été mise à jour de manière similaire, seule la

boîte de dialogue standard Edge Selection s'affiche à la place.



Page 3931-01-2020

Maillage
Edge/Skin Elements (2/2)

Dans la commande Mesh>Edge/Skin Elements>Line Elements on Edges, ajout d'une option permettant de définir

directement l’offset lors de la création des éléments linéiques.



Page 4031-01-2020

Démonstrations

06-rigid.modfem
05-merge-nodes.modfem
07-sweep.modfem
08-skin-edge.modfem
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Page 4231-01-2020

Eléments
Spring Damper

Possibilité d'afficher les systèmes de coordonnées des éléments Spring/Damper qui font références à une propriété avec Type

défini sur CBUSH en utilisant la commande View>Options, en définissant la catégorie sur Labels, Entities and Color en

choisissant Element-Coordinate System dans la liste Options, puis activer Show Coord Sys.



Page 4331-01-2020

Eléments
Formulation Poutre LS-DYNA

Ajout de l’option 13..Timoshenko à la liste déroulante DYNA Options de la boîte de dialogue Beam Element

Formulations.
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Page 4531-01-2020

Charges et Conditions limites

Ajout de la commande Model>Load>Elemental on Face (aussi accessible via le panneau Model Info), identique à

Model>Load>Elemental sauf qu'au lieu de sélectionner directement les éléments où les charges seront appliquées, ici seules

les faces des éléments sont sélectionnées via la boîte de dialogue Face Selection standard.

Seules les charges Pressure, Heat Flux, Convection et Radiation sont disponibles pour être appliquées.



Page 4631-01-2020

Charges et Conditions limites

Mise à jour de la commande Model>Load>From Output pour permettre la sélection de All Output Sets ou Selected

Output Sets pour créer automatiquement de nouveaux Load Set.

De plus, 2 options ont été ajoutées :

Elemental Face Loads : sélection de face

d’éléments

Displacement Loads : création de

conditions de blocages correspondant à des

charges en déplacement (spécificités

Simcenter NASTRAN linéaire)



Page 4731-01-2020

Charges et Conditions limites

Mise à jour de la commande Model>Load>From Freebody en rendant des paramètres supplémentaires disponibles pour la

création automatique d'éléments d'interpolation lors de l'utilisation de l'option Multi-Model.
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Page 4931-01-2020

Connexions
Onglet ANSYS

Ajout de la section Target KEYOPTs et de toutes les options à l'onglet ANSYS.

Cette section contient des options qui ne concernent que les

segments cibles (TARGE169 et TARGA170). La contrainte pilote (4)

est particulièrement intéressante, elle peut être utilisée pour

spécifier des degrés de liberté contraints pour les segments cibles

qui font référence à une propriété de connexion particulière



Page 5031-01-2020

Connexions
Onglet MSC Nastran

Ajout d'une section Thermal à l'onglet MSC Nastran, accessible en cliquant sur le bouton Advanced Options...



Page 5131-01-2020

Connexions
Onglet Autodesk Nastran

Mise à jour du titre de l'onglet pour Autodesk Nastran (anciennement NEi Nastran).



Page 5231-01-2020

Connexions
Onglet Multistep Structural (401)

Mise à jour de l’option *Adaptively Modify Penalty Factor dans l'onglet Multistep Structural (401). Ce paramètre permet de

faire varier de manière adaptative la rigidité de contact entre les itérations. Maintenant c'est une liste déroulante avec trois

options.

“0..Do Not Modify” : le facteur de

pénalité n'est pas modifié (par défaut)

“1..Adaptively Modify” : le facteur de

pénalité est modifié

“2..Adaptively Modify in Large

Range” : Le facteur de pénalité est

modifié dans une plage plus large que

dans le cas 1

Généralement, l’option 1 est un bon

choix pour la plupart des problèmes.



Page 5331-01-2020

Connexions
Onglet Multistep Kinematic (402)

Ajout des options Normal Vel Coeff., Tangent Vel Coeff., Normal Reg. Type, Frict vs Time et Frict vs Temp dans l'onglet

Multistep Kinematic (402).

Normal Vel Coeff. : Choisir une fonction existante qui décrit le

coefficient de vitesse normal par rapport à la distance de

pénétration normale.

Tangent Vel Coeff. : Choisir une fonction existante qui décrit le

coefficient de vitesse tangentielle par rapport à la distance de

pénétration normale.

Normal Reg. Type/Value : Spécifier le type de régularisation

normal.

Friction vs Time : Choisir une fonction existante qui décrit la

relation entre le coefficient de friction en fonction du temps (si

Friction = 1).

Frict vs Temp : Choisir une fonction existant qui décrit la

relation entre le coefficient de frottement vs la température (si

Friction = 1).
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Page 5531-01-2020

Interfaces Solveur

Les interfaces FEMAP suivantes ont été mises à jour pour prendre en charge les nouveaux formats de solveur :

Interface FEMAP Dernière version supportée

FEMAP Neutral 2020.1

ABAQUS ABAQUS 2019

ANSYS ANSYS 19.0

I-DEAS I-DEAS 9.0

LS DYNA LS-DYNA R11

LSC Marc 2005

Simcenter Nastran (NX Nastran) 2019.2

AutoDesk Nastran (Nei Nastran) 2019 R2

MSC Nastran MSC Nastran 2018



Page 5631-01-2020

Interface Solveur
Simcenter Nastran SOL402 et SOL401

Ajout de la section Restart Parameters (SOL 401 et SOL 402) à la boîte de dialogue Multi-Step Global Control Options.



Page 5731-01-2020

Interface Solveur
Simcenter Nastran SOL401 (1/4)

Ajout de trois options à la section Solution Parameters de la boîte de dialogue Solution and Convergence Options.



Page 5831-01-2020

Interface Solveur
Simcenter Nastran SOL401 (2/4)

Ajout de trois options à la section Stiffness Parameters de la boîte de dialogue Solution and Convergence Options.



Page 5931-01-2020

Interface Solveur
Simcenter Nastran SOL401 (3/4)

Ajout de quatre options à la section Convergence Parameters de la boîte de dialogue Solution and Convergence

Options.



Page 6031-01-2020

Interface Solveur
Simcenter Nastran SOL401 (4/4)

Ajout d’une option à la section Time Integration de la boîte de dialogue Solution and Convergence Options.



Page 6131-01-2020

Interface Solveur
Simcenter Nastran SOL402 (1/5)

Ajout de deux options à la section Global Parameters (SOL402) nouvellement créée de la boîte de dialogue Multi-Step

Global Control Options.



Page 6231-01-2020

Interface Solveur
Simcenter Nastran SOL402 (2/5)

Ajout de trois options à la section Advanced Parameters (SOL402) nouvellement créée de la boîte de dialogue Multi-Step

Global Control Options.



Page 6331-01-2020

Interface Solveur
Simcenter Nastran SOL402 (3/5)

La section Other Options a été divisée en Plasticity and Creep Control et Internal Restart et le nom du bouton

Solution/Convergence a été changé en Iteration and Convergence.



Page 6431-01-2020

Interface Solveur
Simcenter Nastran SOL402 (4/5)

Ajout de trois options à la boîte de dialogue Multi-Step Control Options, deux dans la section Time Stepping et une dans

la section Analysis Control.



Page 6531-01-2020

Interface Solveur
Simcenter Nastran SOL402 (5/5)

Ajout de deux options à la boîte de dialogue Solution and Convergence, une dans Equilibrium Iteration and

Convergence et une dans Contact.



Page 6631-01-2020

Interface Solveur
Nastran Simcenter/MSC/MD (1/5)

• Impression des résultats dans le fichier de résultats f06 dans la rubrique
STRUCTURAL INTEGRATED FREEBODY MONITOR POINT LOADS (MONPNT3)

• Création, édition, visualisation, gestion possible via

o L’Arbre Model Info/

o Le menu Model/Simulation Entities

o Les API

Prise en charge de la lecture/écriture pour les cartes NASTRAN MONPNT1 et MONPNT3 (Monitor Point) :



Page 6731-01-2020

Interface Solveur
Nastran Simcenter/MSC/MD (2/5)

Ajout d'un élément Monitor Points dans Analysis Set Manager pour un certain nombre de types d'analyse différents, ce

qui permet d'accéder à la boîte de dialogue Select Monitor Point(s).



Page 6831-01-2020

Interface Solveur
Nastran Simcenter/MSC/MD (3/5)

Prise en charge de la lecture/écriture de la carte NASTRAN DMIG (Direct Matrix Input) :

Création, édition, visualisation, gestion possible via 

o L’Arbre Model Info

o Le menu Model>Simulation Entities

o Les API



Page 6931-01-2020

Interface Solveur
Nastran Simcenter/MSC/MD (4/5)

Ajout de l'élément Direct Matrix Input dans Analysis Set Manager pour un certain nombre de types d'analyses différents,

ce qui donne accès à la boîte de dialogue NASTRAN Matrix Input Selection.



Page 7031-01-2020

Interface Solveur
Nastran Simcenter/MSC/MD (5/5)

Prise en charge d’identifiants supérieurs à 99 999 999. Toute entité avec un «grand ID» sera automatiquement écrite en

grand format. Il appartient à l'utilisateur de confirmer que tout type d'entité auquel a été attribué un "Large ID" est autorisé à

avoir un "Large ID" pour la séquence de solution spécifiée dans le solveur spécifié.



Page 7131-01-2020

Interface Solveur
ANSYS (1/4)

Ajout de l’option Portion of Model to Write dans la section Model Control de la boîte de dialogue ANSYS Command and

Model Control.

Permet de sélectionner un groupe précédemment défini, puis d'exporter uniquement les entités prises en charge dans ce

groupe vers le fichier d'entrée ANSYS.



Page 7231-01-2020

Interface Solveur
ANSYS (2/4)

• Amélioration des éléments de coque avec des épaisseurs de coque variables définies via * DIM et * SET, SECFUN.

• Amélioration des entrées ESEL et NSEL en créant des groupes FEMAP lorsqu'ils se rencontrent. De plus, les groupes

dans FEMAP peuvent être utilisés pour écrire des entrées ESEL et NSEL.

• Amélioration des charges et des contraintes à l'aide des éléments ou des nœuds ANSYS



Page 7331-01-2020

Interface Solveur
ANSYS (3/4)

Mise à jour  de la boîte de dialogue utilisée pour la spécification des informations PSD et d'autres options pour l'analyse de 

réponse aléatoire.



Page 7431-01-2020

Interface Solveur
ANSYS (4/4)

• Même apparence que l'analyse aléatoire

Simcenter Nastran.

• Limitation: le résultat du spectre doit être

traité dans ANSYS, à l'aide de la

commande POST26, RPSD.

Possibilité de prendre en charge plusieurs excitations (self PSD et cross PSD).



Page 7531-01-2020

Interface Solveur
ABAQUS

• Prise en charge en lecture/écriture des cartes pour DLOAD, TRVEC pour créer/exporter des charges de pression

directionnelles.

• Prise en charge de la lecture des types de SECTION * CONNECTEUR BUSHING et BEAM.

o Pour type = BUSHING, des éléments Spring/Damper sont créés.

o Pour type = BEAM, des éléments Spring/Damper avec de très grandes valeurs de rigidité dans toutes les directions,

sont créés.

• Prise en charge de la lecture de CONTACT PAIR, SURFACE INTERATION et SURFACE NAMEs et de leur conservation

dans FEMAP.

• Prise en charge de la lecture des termes hors axe à partir des entrées INERTIE ROTATIVE, qui sont stockées en tant

qu'éléments de masse dans FEMAP.

• Mise à jour pour lire un maximum de 9 chiffres pour les ID dans le fichier d'entrée ABAQUS.

• Suppression de la prise en charge de l'importation de fichiers au format fixe, car désormais incompatibles avec le solveur.



Page 7631-01-2020

Interface Solveur
LS-DYNA (1/2)

Ajout de l’option Portion of Model to Write dans la boîte de dialogue LS-DYNA Model Options. Permet de sélectionner un

groupe précédemment défini, puis d'exporter uniquement les entités prises en charge dans ce groupe vers le fichier d'entrée

LS-DYNA.



Page 7731-01-2020

Interface Solveur
LS-DYNA (2/2)

• Ajout de la prise en charge du type de poutre «13..Timoshenko». Dans FEMAP, cela

est défini à l'aide d'une formulation d'élément.

• Améliorée des éléments de coque avec des épaisseurs variables définies à l'aide des

champs ELEMENT_SHELL_THICKNESS.



Page 7831-01-2020

• Interface

• Géométrie

• Maillage

• Eléments

• Charges et Conditions Limites

• Connexions

• Interfaces Solveurs

• Post-traitements

• Divers

• Conclusion



Page 7931-01-2020

Post-traitements
Digits (1/2)

Les options suivantes dans View Options contiennent un bouton Digits qui peut être utilisé pour remplacer les options

définies dans les Préférences.



Page 8031-01-2020

Post-traitements 
Digits (2/2)



Page 8131-01-2020

Post-traitements
Iso surface

Possibilité, lors du traçage d'une IsoSurface, d'utiliser une seule IsoSurface comme une limite, qui permet d’afficher tous les

éléments qui ont une valeur inférieure à la valeur spécifiée (2..Negative Capped Isosurface) ou supérieure la valeur spécifiée

(3..Positive Capped Isosurface).

Cette option peut être contrôlée par l'option IsoSurface dans View Options ou via le menu déroulant lors de l'utilisation de

«Dynamic IsoSurface».



Page 8231-01-2020

Post-traitements
Section Cut

Ajout de la possibilité, lors de la visualisation type Section Cut, option Cut Model, de choisir si l'affichage montre tous les

éléments du côté du plan négatif normal (0..Negative Cap) ou plan positif normal (1..Positive Cap).

Ces options peuvent être définies via le menu View>Advanced Post>Dynamic Cutting Plane ou le menu dynamique

Dynamic Control de la section Cut Options.
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Post-traitements
Changement des ID de résultats (1/5)

Les plages ID des vecteur de sortie dans les versions précédentes de FEMAP ne peuvent pas prendre en charge un grand

nombre de nouveaux codes et des nouveaux types d'éléments FEMAP.

Pour permettre l'ajout continu de nouveaux codes, certains des vecteurs existants ont été déplacés vers de nouvelles plages

d'ID.

Le tableau suivant montre les anciennes et les nouvelles plages d'ID de vecteur de sortie (en orange, celles qui changent) :

Comparaison des plages  de vecteur de résultats

Type de résultats
Plage de vecteur depuis

9.3 jusqu’à 2019.1

Plage de vecteur depuis

2020.1

Nodal output 1 to 2,999 1 to 2,999

Line element output 3,000 to 5,999 3,000 to 5,999

Plate element output 6,000 to 7,599 6,000 to 9,999

Plate corner output 100,000 to 299,999 10,000 to 25,999

Not currently used 7,600 to 59,999 26,000 to 59,999

Solid element output 60,000 to 69,999 60,000 to 69,999

Solid corner output 70,000 to 73,999 70,000 to 79,999

Output on any element type 80,000 to 89,999 80,000 to 89,999

PATRAN elemental output 90,000 to 99,999 90,000 to 99,999

Comparaison des plages  de vecteur de résultats

Type de résultats
Plage de vecteur depuis 9.3 

jusqu’à 2019.1

Plage de vecteur depuis

2020.1

Not currently used 300,000 to 999,999 100,000 to 999,999

Plate Laminate Ply output 1,000,000 to 1,999,999 1,000,000 to 3,999,999

Plate Laminate Ply corner 2,000,000 to 5,999,999 4,000,000 to 15,999,999

Solid Laminate Ply output 6,000,000 to 6,499,999 16,000,000 to 17,499,999

Solid Laminate Ply corner 6,500,000 to 8,499,999 17,500,000 to 23,499,999

User Defined output 9,000,000 to 9,999,999 24,000,000 to 24,999,999

Complex Phase output Add 10,000,000 to above ranges Add 25,000,000 to above ranges

Complex Real output Add 20,000,000 to above ranges Add 50,000,000 to above ranges

Complex Imaginary output Add 30,000,000 to above ranges Add 75,000,000 to above ranges
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Post-traitements
Changement des ID de résultats (2/5)

• Si un modèle (antérieur à FEMAP 2020.1) est ouvert ou un fichier neutre est importé dans la nouvelle version 2020.1, les

ID des vecteurs sont mis à jour automatiquement.
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Post-traitements
Changement des ID de résultats (3/5)

Si un script ou un programme API contient des appels, des méthodes ou des propriétés obsolètes concernant les ID de

vecteur de sortie, la boîte de dialogue Obsolete API Warning obsolète apparaît et des messages apparaitrons dans la

fenêtre Messages.
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Post-traitements
Changement des ID de résultats (4/5)

• De nouvelles méthodes et propriétés d'API ont été ajoutées sur divers objets API pour fonctionner sur les nouveaux ID

de vecteur de sortie. De plus, des appels API ont été ajoutés pour convertir les anciens ID de vecteur en nouveaux et

vice versa :

o feOutputConvertV2019VectorIDToV2020V2(v2020VecID)

o feOutputConvertV2020VectorIDToV2019V2(v2020VecID)

• De nouveaux objets API pour spécifier la sortie par de nouvelles quantités prédéfinies, telles que «Top Von Mises

Stress», au lieu d'avoir à connaître un ID de vecteur spécifique, ce qui éviterait d'avoir à recoder les API à l'avenir, si les

ID de vecteur changent encore :

o ResultsIDQuery

• Les objets Output deviennent obsolètes et doivent être remplacés par des objets Results
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Post-traitements
Changement des ID de résultats (5/5)

• Si on utilise l’ancienne méthode

rc = RBO.AddColum(nSetID, 7433, False, nCol, cIndex) 

Exemple : Plate Bottom von Mises Stress 

ID FEMAP V2019.1 : 7433 

ID FEMAP V2020.1 : 9033 

Message 

d’avertissement

• Si on connait l’ID du résultat en version 2020.1 :

rc = RBO.AddColumV2(nSetID, 9033, False, nCol, cIndex) 

• Si on ne connait pas l’ID du résultat :

Dim lookUpID As femap.ResultsIDQuery

Set lookUpID = App.feResultsIDQuery

Dim botVonMisesID As Long

botVonMisesID = lookUpID.Plate(VPV_STRESS, VPT_VON_MISES, VPP_BOT, VPL_CENTROID)

rc = RBO.AddColumV2(nSetID, botVonMisesID, False, nCol, cIndex) 
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Démonstration

10-results-2D.modfem
10-results-3D.modfem
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• Interface

• Géométrie

• Maillage

• Eléments

• Charges et Conditions Limites

• Connexions

• Interfaces Solveurs

• Post-traitements

• Divers

• Conclusion
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Divers
List

Mise à jour de la commande List>Tools>Layers pour répertorier éventuellement les entités sur les Layers, les groupes avec

des layers de référence et/ou les layers qui sont un layer visible par View. De plus, peut désormais aussi lister les « layers

manquants" et les « layers vides".
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Divers
Groupe et Layers

Ajout de la possibilité d'utiliser des commandes spécifiques dans le menu Group, pour tout type d'entité qui existe dans le

modèle, même si aucun groupe n'existe dans le modèle. Lorsqu'une commande de menu Group est utilisée dans cette

situation, l'utilisateur est invité à créer un nouveau groupe.

Pas de groupe initialement créé

(section vide)
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• Interface

• Géométrie

• Maillage

• Eléments

• Charges et Conditions limites

• Connexions

• Interfaces Solveurs

• Post-traitements

• Divers

• Conclusion
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Simcenter Femap 2020.1
Bilan

Total : 93 évolutions

rubrique nb rubrique nb

User Interface 21 Renumbering x

Geometry 7 Listing 1

Meshing 10 Connections 5

Element 2 Optimization x

Element Update x Group and Layers 2

Material x Views 2

Properties x Output Post Processing 3

Aeroelasticity 2 Interfaces 29

Layup x Tools 3

Load and  Constraint 3 Preferences 3

FEMAP 2020.1 : Nombre d'évolutions

11.2 11.3 11.4 12 2019.1 2020.1

(Mars 2015) (Mai 2016) (Juin 2017) (Octobre 2018) (Mai 2019) (Janvier 2020)

149 181 68 133 86 93

FEMAP
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Divers
Evènement

Hall 6 - Stand L 91 
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Divers
Catalogue Formations SIGMEO 2020

A M 1 S 1 D 1 M 1 A V 1 L 1

B J 2 D 2 L 2 J 2 S 2 M 2

C V 3 L 3 M 3 V 3 D 3 M 3

S 4 M 4 M 4 S 4 L 4 J 4

D 5 M 5 A J 5 D 5 M 5 V 5

L 6 J 6 V 6 L 6 M 6 S 6

M 7 V 7 S 7 M 7 J 7 D 7

M 8 S 8 D 8 M 8 V 8 L 8

J 9 D 9 L 9 C J 9 S 9 M 9

V 10 L 10 M 10 V 10 D 10 M 10

S 11 M 11 M 11 Composite S 11 L 11 J 11

D 12 M 12 J 12 D 12 M 12 V 12

L 13 C J 13 V 13 L 13 M 13 S 13

M 14 V 14 S 14 M 14 J 14 D 14

M 15 S 15 D 15 A M 15 V 15 L 15

J 16 D 16 L 16 B J 16 S 16 M 16

V 17 L 17 M 17 C V 17 D 17 M 17

S 18 M 18 M 18 S 18 L 18 J 18

D 19 B M 19 J 19 D 19 M 19 V 19

L 20 C J 20 V 20 L 20 M 20 S 20

M 21 V 21 S 21 M 21 J 21 D 21

M 22 S 22 D 22 A M 22 V 22 L 22

J 23 D 23 L 23 B J 23 S 23 M 23

V 24 L 24 M 24 V 24 D 24 M 24

S 25 A M 25 M 25 S 25 L 25 J 25

D 26 B M 26 J 26 D 26 M 26 V 26

L 27 J 27 V 27 L 27 M 27 S 27

M 28 V 28 S 28 A M 28 J 28 D 28

M 29 S 29 D 29 M 29 V 29 L 29

J 30 L 30 J 30 S 30 M 30

V 31 M 31 D 31

A-B-C : Zones vacances scolaire

JuinJanvier Février Mars Avril Mai

FEMAP 

SOL402

22

05
18

04 17

26

13
09

FEMAP 

SOL402

25

12

08

21

27

14

FEMAP Init 

avec 

Nastran

02 15

FEMAP 

Avancé

03 16

01

24

11

FEMAP API

07

20

FEMAP Init

10

06

19

05

14

18

23

Plannification Formations Inter Entreprise 2020

Janvier Février Mars Avril Mai Juin
M 1 C S 1 M 1 J 1 D 1 M 1

J 2 D 2 M 2 V 2 L 2 M 2

V 3 L 3 J 3 S 3 M 3 J 3

S 4 M 4 V 4 D 4 M 4 V 4

D 5 A M 5 S 5 L 5 J 5 S 5

L 6 B J 6 D 6 M 6 V 6 D 6

M 7 C V 7 L 7 M 7 S 7 L 7

A M 8 S 8 M 8 Composite J 8 D 8 M 8

B J 9 D 9 M 9 V 9 L 9 M 9

C V 10 L 10 J 10 S 10 M 10 J 10

S 11 M 11 V 11 D 11 M 11 V 11

D 12 A M 12 S 12 L 12 J 12 S 12

L 13 B J 13 D 13 M 13 V 13 D 13

M 14 C V 14 L 14 M 14 S 14 L 14

A M 15 S 15 M 15 J 15 D 15 M 15

B J 16 D 16 M 16 V 16 L 16 M 16

C V 17 L 17 J 17 S 17 M 17 J 17

S 18 M 18 V 18 D 18 M 18 V 18

D 19 A M 19 S 19 L 19 J 19 S 19

L 20 B J 20 D 20 M 20 V 20 D 20

M 21 C V 21 L 21 A M 21 S 21 L 21

A M 22 S 22 M 22 B J 22 D 22 M 22

B J 23 D 23 M 23 C V 23 L 23 A M 23

C V 24 L 24 J 24 S 24 M 24 B J 24

S 25 M 25 V 25 D 25 M 25 C V 25

D 26 A M 26 S 26 L 26 J 26 S 26

L 27 B J 27 D 27 A M 27 V 27 D 27

A M 28 C V 28 L 28 B M 28 S 28 L 28

B M 29 S 29 M 29 C J 29 D 29 M 29

C J 30 D 30 M 30 V 30 L 30 M 30

V 31 36 L 31 S 31 J 31

Décembre

A-B-C : Zones vacances scolaire

Juillet Aout Septembre Octobre Novembre

35

44
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30

39

48

51

FEMAP Init

47

34

FEMAP Init

43

FEMAP 

Avancé

40
01

52

28

FEMAP 

SOL402

37

29

38

36

40

33

42

49

45

32

41

Septembre Octobre Novembre Décembre

27

50

46

Plannification Formations Inter Entreprise 2020

Juillet Aout
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Divers
Optimisation Topologique

Nécessité d’une licence spécifique pour utiliser le module d’optimisation Topologique SOL200 Topology Optimization
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Divers
Licence Etudiant Gratuite

Possibilité de télécharger une version gratuite FEMAP pour Etudiant :

• La version est disponible uniquement pour les étudiants 

• Le fichier binaire .modfem n'est pas compatible avec la version industrielle 

• Elle est limitée à un modèle éléments finis de 32 000 Noeuds

• Idéal pour un stagiaire lors de la création de modèle FEM ou/et 

développement API

• Solveurs disponibles : NX Nastran Basic + NX Nastran Dynamic

https://www.plm.automation.siemens.com/plmapp/education/femap/fr_fr/free-software/student

https://www.plm.automation.siemens.com/plmapp/education/femap/fr_fr/free-software/student
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Merci pour votre attention

Questions ?
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